Go-tcha tick change issues


#1

I recently purchased a Go-tcha and it was working perfectly fine, no issues until the tick that is meant to be showing to allow you to connect to your device, on the Go-tcha is now a cross and every time i try holding down the button to change it to a tick the screen will flash until it resets itself. On all the other functions i am able to change from cross to tick apart from the one that allows me to connect to my device. Ive tried forgetting the device and reconnecting but now the device is not even showing. Any ideas would be much appreciated.


#2

Hey honestly I can’t help much but to me sounds like it may be faulty or damage to would be best to contact the provider. Also you may get a bit more help posting in support rather than general discussion :slight_smile:


#3

I’ve had this problem before, and it got solved by forgetting the go-tcha from every phone you’ve connected the go-tcha to in Bluetooth settings. Or You can try to hard reset it by plugging the go-tcha into the charger and then quickly plug that charger in and out of a power bank or an outlet 10-20 times. There is also an app for it to IOS, called “Go-tcha Updater”.


#4

You don’t connect it to your device by selecting the tick. It pairs up by just taping the device and the check box ticks itself once its paired.
Step 1. Make sure your Gotcha is charged up. An almost flat Gotcha doesn’t Pair up well or will drop connection soon after Pairing. 2hrs is enough to fully charge it.
Step 2. Reset the Gotch by as described above by taking it in and out of the Charger 10 times. Make sure power to charge is on and it’s touched the connections when doing this. It wont give you any indication its done anything.
If it still wont Pair up to your device than go to step 3.
Step 3. Completely wipe the Gotcha from your Devices Blue Tooth options so it has no memory of the Gotcha
Step 4. Re setup the Gotcha on your Device just like you did the very first time.

I’ve used all the above options to get mine going a few times now.
Most of the time the 10 times reset has fixed the Pair up issue.
A few times I’ve had to delete and Re set it up.


#5

Having exactly the same problem. the fifth screen, showing the “connect to device” animation, has an X that I can’t change to a check mark. I’ve “forgotten” the device, reinstalled PoGo app, tried reconnecting, etc. but nothing has changed the fact that the Go-tcha won’t change from X to CHECK as far as allowing pairing. Tried all four steps from Notanotherkangaskhan…


#6

It’s true you don’t connect by changing it to a tick. But I think it’s also true that the app won’t connect when the box is set to X.

At the very least, the app won’t connect to a Go-tcha that doesn’t allow the user to change the mark to a tick, to describe my problem.


#7

Hold button it down while on that screen till the x goes away


#8

In case anyone is still having issues, this resolved it for me-

This video shows the person having the same issue as me:

one of the comments below recommended you connect to the gotcha while it’s charging
steps I did

  1. forget the gotcha in the bluetooth settings
  2. plug gotcha into charging cable
  3. launch pogo and go to the pokemon gotcha submenu
  4. tap on the gotcha to turn on the screen (while it’s charging)
  5. it should ask if you want to pair
  6. pair it, and for me it didn’t do anything
  7. however after that point, the x did finally change to a check
  8. i went to my bluetooth settings and disconnected the device
  9. disconnected gotcha from charging cable
  10. launch the pogo app and went to gotcha submenu to reconnect the device

for some people it might be different, but once you get the x to change to a check then you can proceed with pairing it

hope this helps


#9

Latest Solution as of 08/01/2018- This worked on both an old Pokemon Go-tcha and a brand new one out of the box with the “X” permanently stuck on the pairing mode screen and device not pairing. Draining battery and 10 quick in and outs to reset did not work for me. This did on the iPhone:

  1. Go to your phone’s Bluetooth settings and Forget the Pokemon Go Plus device
  2. Plug the Go-Tcha into the charging cable.
  3. Launch Pokemon GO and go to the Pokemon Go Plus submenu
  4. Tap on the red Go-tcha circle to turn on the screen (while it’s charging)
  5. Go-tcha should show up in the PoGo submenu under AVAILABLE DEVICES
  6. Close Pokemon GO and OPEN the Go-tcha Update App. This resets its little brain and is key.
  7. Let it Sync, do whatever it pleases and it rewards you with the check mark in the pairing screen. Make your settings from this application if at all possible.
  8. Close the Go-tcha app, disconnect from charger and open Pokemon Go.
  9. Connect the Go-tcha and pair if necessary.

This worked for me after many, many other solutions were tried and I even bought a new Go-tcha only to have the same issue out of the box.