Go Sync not Working

Had Sync working with Google Fit on my Samsung without issues since Sync came out.

Start of March I got a Huawei P20 Pro, and was debatable if Sync was working or not. Mid week last week however, an update came through for my phone, going from Android 8 to 9.

As always, I like a clean slate when that happens so, did a full factory reset, installed the update, then cleared the phone system cache. Installed Pokemon Go, installed FIT, both set to the same gmail account, checked and permissions are granted, storage is enabled.

I also switched my buddy to a Wailmer (100IV + Lucky… definitely evolving that one).

Saturday, I was out and FIT recorded 2.6km. I checked my Pokemon app which was closed, not running in the background. Opened and looked and 0 progress. Waited a full day, and still 0km showing for Wailmer. Today, 9pm, got the total for the week, and didn’t count any of it so, fell short of the 5km minimum.

Cleared the cache for both apps, and restarted the phone yesterday, but still not seeing any of the progress either.

Any suggestions?

I’m uninstalling both right now and reinstalling again. Apart from that, what else can be done?

1 Like

It happens sometimes there have been times where I did almost zero walking and still got distance it goes back and forth sometimes sorry I don’t have any idea how to fix this I’ve had this problem for a while now

I had it for the first month when it came out, so I already knew all the things to check/test. That said, it was on Android 8, not 9… not sure if Android 9 had a new set of issues or not.

The Huawei had it’s own fitness tracker that I uninstalled thinking maybe it conflicted or something.

In the meanwhile, I just finished doing a force stop, delete cache, delete data, then uninstall of both apps. Installed in the reverse order than I did last time. Installed Google Fit, logged in and set up. Then installed Pokemon Go. Enabled Sync, said it was connected. Checked under Google Apps, Fit and Permissions and listed Pokemon Go. Also noticed that (same as last time) it had the ‘use storage’ disabled under permission for both apps, I read that may be an issue so enabled local storage for both just to be sure.

I’ll give it a week, see how it goes I guess.

I also read that if Pokemon Go was running in the background it defaults to it for walking/movement not the Google Fit data, so, I’m making sure that Fit is running and no other apps are in the background at all.

Mostly annoyed because my average week is 4.5km… the extra 2.6km on the weekend woulda been just what I needed to get that 5km minimum… and I got nadda again. :S

Summer in Canada is coming soon, so, will start walking more again… but in Winter, that 5km minimum when you live in a remote village with nothing to do, is tricky to get. :smiley:

1 Like

Did you had your cellphone on the “highest” battery saving on?
Pokemon background feature is stopped if you get your cellphone battery saving on. You need to disable it, when you go for a walk. Easiest way, disable your mobile internet and connect it again, when you get to the end. Best way to get it counted (you did enable the sync on pokemon go did you?). Even my old Android 4.4 cellphone still gets it. It can fail sometimes (low on resources to use and fails to send when i get wifi available) but it will count sometime later.

Nope, no battery saving at all actually. I’ll play Pokemon maybe half an hour a day, and otherwise phone stays off and in my pocket. Not really one for txt’ing, and anything else, I have a PC for. Company phone, otherwise probably wouldn’t have one. :smiley:

But no, everything disabled. Only think enabled under battery power is to alert when low.

And yup… Adventure Sync is enabled.

Well… everything was cleared, uninstalled, reinstalled, re-enabled and permissions granted so, I guess, see how it is next Monday.

Especially annoyed because have a task to get 5 candies with my buddy, and buddy is Wailmer so 1km per Candy, and after 6 days, it shows 0.1km total. Checked and so far earned 0 candies so, didn’t get candy and roll over again.

1 Like

Seems fine now… maybe just the order in which stuff is installed and enabled?

1 Like

I have the effect sometimes, but click in the diary and leaving it normally it put it in work again.

1 Like

I have no idea what you are saying… click in the diary?

1 Like

If you look your player, there are three buttons. The left for your buddy, the center for the diary and the right to personalize your player (like changing the hat, the hairstyle, etc).
Just using the center-button for the diary which shows the last pokemon caught, the gifts from the stop…

When you leave this diary, the game charges again the data from the servers, and in many situation this gets you out of a blocked game.

1 Like

Hmm… not sure how looking at your journal corrects a sync issue with Google Fit. Maybe updates the current progress… but if it’s not syncing at all I don’t think looking at the journal will correct that.

1 Like

He is talking about the journal the way he wears things a little bit different but if you pay attention he makes sense

Yes, I know… that’s why in my response I referred to it as journal.

Wording aside, I still don’t see how that would fix the sync issue. Update the sync, yes… but fix a broken sync, no.

1 Like

It goes back and forth for me one week it’ll work perfect the next week it won’t work at all sometimes it’ll give me distance I never even earned

Going out of the journal, the app calls the function osomething like a reset of all variables.
If you have trouble with the map, enter the journal and go out.
You cannot see your friendlist, the same.

I’m quite shure Go Sync is working, it’s just that the data doesn`t reach the involved variables.

1 Like

I did not know that either I’m going to have to try that

Nope, it wasn’t working. Uninstall/reinstall in a different order fixed it though.