Device "Incompatibility"

Hello everyone! After a two and a half year hiatus, I have decided to come back and give Pokémon Go another shot. However, after installing the app, when opening the game I get a notification that says “This device, OS, or software is not compatible with Pokémon Go.”

The issue is I only get this notification SOMETIMES. Id say 60% of the time when I open it, the game immediately goes to this screen. However I have gone almost half an hour while playing it before something happens and the game says its incompatible. Ive looked through the list of requirements that the game needs according to the “Help Center” and I meet everything that is listed. I have a friend that also plays on the exact same phone as mine (Samsung Galaxy S7) and hasn’t had a single issue with it.

Ive tried uninstalling it, brute forcing it, and ive tried to figure out if there was something specific that causes it, but to no avail. It seems almost random, and I was hoping someone might be able to help me out with this issue.

I dont know what information I can give you, but ill say that I am using a google account, on an unrooted device. Please let me know if you guys have any suggestions!

Because I am a new user I cant post two pictures, so ill post the actual incompatibility screen. Ill post the game itself if someone thinks it would be valuable in some way.

1 Like

Let’s start with crucial info what os version?

It’s not the phone, might be a badly registered version of the os on the phone.

Do you run a beta or is your phone rooted?

Also look for a folder with the name “MagiskManager”. Delete that folder after the app is removed.

1 Like

Im currently running on Android “Oreo” 8.0.0. Im not sure if the “Samsung Experience Version” has anything to do with it, but it is 9.0.

The phone is not rooted. As far as I know it isn’t a beta, but i’m not aware of how to check this.

Where is the “MagiskManager” folder located? I glanced through “My Files” and after searching for it I couldnt find it.

Thank you for the quick reply :slight_smile:

Edit: Im not sure if this helps at all, but a few weeks ago I factory reset my phone. I dont know if that would change anything, but I thought it might be worth mentioning.

Factory resets is suppoost to help.

Where did you downloaded the app from, Google play store or the Samsung store?

If you think itll help I can do another factory reset, but I did one last month.

I downloaded the app from the Google Play Store.

Delete it and try the app from the samsung store

I installed it from the Galaxy Store. It looked like it worked at first, but I got the same error message :confused:

I’m out of suggestions.
Contact Niantic as a last resort. Reddit didn’t came up with an other fix. either.

Damn :confused: Well, thank you for your help. I really appreciate it!


Sorry, is the only way to contact them through the help center/ticket system they have? If so, I already emailed them a while ago with my issue. Is there any sort of 1 on 1 support?

No not really. Twitter is more direct, but mostly PR-approved crap-talk that is useless. I think the only thing you can do is wait and hope the next version does not have this and is soon released.

Rip, alright thanks

Good luck

1 Like

Did you installed calcIV or some other “adds” for POGO?
Had a friend that had that trouble last year with he 8.0 update. He removed the calcIV, reinstalled POGO and it was working. Had to wait 3 months until calcIV got an update that wouldn´t trigger that warning.

Where did you read that? Calcy IV is safe. I have as a secondary, but never seen this message.

I’m using it continouisly since 2017 (in my account and my friend as well), and there was never a problem.

And really, not even legally there can be a problem, because it’s only taking a “photo” of the screen. And nobody can make problems with that.


Nope, I dont have any additional apps that should affect it at all. No Calcy, no location spoofing, no macros, no autoclickers, no nothing :confused:

1 Like

Did Niantic respond yet?

1 Like

Got an automated response for the email, but I have to keep clearing the cache and data on the app to be able to log back in, so its a bit difficult to actually get a response.

Still waiting :confused:


Found mentions of the following apps that could give this problem: Lucky Patcher, & SuperSU.

Also check the play store for updates and check if your phone has a firmware update. If that is not the case, empty the cache of the play store.

That is what I came across looking around.