Adventure sync won't work

Hi all!

Hoping someone might know. I have done all the Google search, gone into all the FAQs and tried lots of YouTube fixes but still can’t get my adventure sync to work.

I have a Redmi note 7 (which uses miui 10) with Mi fit and Google fit, plus I have a mi band 4.

I’ve tried uninstalling and reinstalling, all the battery saving, all the permissions and linking apps.

As soon as I select “adventure sync” in the pogo settings I get the popup (added to this post) and it stays on that. I’ve left it for literally an hour before and it gets no further. I always have to back out of it and then it tells me adventure sync failed.

If anyone has any ideas because it’s driving me insane! I’ve been trying for months now.


I have a Max 3 of Xiaomi with miui 10 and without any problem with the adventure sync, so the failure isn’t coming from there. There has to be another reason in your configuration.

Thanks, I’m lost though. I think I have tried all the suggestions I could find online.

Check this way-
Hope it will work

1 Like